WELCOME TO SixValley APP


Introduction

  • SixValley is a flutter and dart based Android and iOS app. Where flutter is an open-source UI software development kit created by Google. It is used to develop applications for Android, iOS, Linux, Mac, Windows, Google Fuchsia, and the web from a single codebase. Fuchsia, Flutter widgets incorporate all critical platform differences such as scrolling, navigation, icons, and fonts to provide full native performance on both iOS and Android.

  • Dart is a client-optimized programming language for apps on multiple platforms. It is developed by Google and is used to build mobile, desktop, server, and web applications. Dart is an object-oriented, class-based, garbage-collected language with C-style syntax. Dart can compile to either native code or JavaScript.

Requirements

  • To edit this project you must have Flutter and Dart installed and configured successfully on your device Install flutter
  • Set up your editor Install the Flutter and Dart plugins

Getting started with SixValley

  • After download and unzip the package, use preferred IDE (Android Studio / Visual Code / IntelliJ) to open the project flutter e-commerce folder.
  • Click the Get dependencies or Packages get to install the libraries from pubspecs.yaml file.
  • Make sure dart sdk is up to date / get dark packages
  • Open the simulator or connect real android device to run the project.
  • Then press the run button to start project (you can still open multi simulator at the same time)

Flutter version required

  • Flutter version 2.0